Auto Wiper Problem - Fixed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-12-08 Thread Starter
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Chilling Auto Wiper Problem - Fixed

I've had a wiper problem with my Brera since it was new

The problem being erratic wiping when on 'auto-mode' and contined wiper movement even after the stalk was set to the off position and after using the 'flick wipe' (although this only occurred only at 'motorway speeds' officer )

One dealer's remedy to the problem was to (allegedly ) replace the entire rear view mirror assembly - I have Auto-Lights too - which only resulted in the whole unit being loose and moving when you adjust the rear-view mirror

Any Hoo... I mentioned the problem to HRO's Chief Tech when I dropping her off for the 36k service a couple of weeks ago and he immediately suggested three possible causes of the fault:

1. Steering Column Stalk unit.
2. Wiper Motor
3. Body Computer

So we decided to go with the easiest option of the elimination process first i.e. Replacing the Stalk unit

The part was ordered and arrived 3 days later... I was booked in for a 'while you wait fitting' so popped down last Wednesday afternoon at the agreed time and 40 minutes later I was on my way

And I'm happy to report - after driving in the damp & rain on Sunday evening.... hey presto... sorted

So full marks yet again to HRO

And I will strike down upon thee with great vengeance and furious anger those who attempt to poison and destroy my brothers. And you will know I am the Nomes when I lay my vengeance upon you.
AO Bratpacker No1
*Muppet Attack Mode Activated*
nomad is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

auto , fixed , problem , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome