Rear Brake light problem on Brera.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-12-08 Thread Starter
Status: -
AO Member
Join Date: May 2007
Location: United Kingdom
County: Cardiff
Posts: 16
Hmmm Rear Brake light problem on Brera..


Recently got a warning up saying my rear brake light had failed.
After changing the bulb which was no meant feat in itself, it still does not light and i am still get the warning lights for it.

I have tried three new bulbs which are fine and have also tested the original one as well to and thats fine to.

Any ideas any one ?

Smudge2k is offline  
Sponsored Links
Status: shush !! what's that rattle ?
AO Member
frozen-north's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Aberdeen
Posts: 335
Images: 1

Member car:

Brera 3.2 Q4 SV

Re: Rear Brake light problem on Brera..

Hey Steve

Sounds like the wiring to the light fitting has come adrift somewhere. That would give the same effect as a blown bulb to the circuit. Don't know too much about the electrical circuits but if you can get hold of a multimeter and test for a voltage at the connector that would confirm things ... or not.
frozen-north is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brake , brera , light , problem , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome