Problem with 159 rear elec windows - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-07-08 Thread Starter
Status: -
Join Date: May 2008
Posts: 5

Member car:


Problem with 159 rear elec windows

hi all, help required if poss?

i have suddenly lost the power from my rear windows neither the driver switch no the door switches work.
The window lock is definitely not on.

Is there an override of some sort that could have locked them, my daughter was opening and shutting hers a bit, not excessively.
If so how do i get them free again?

If not is it just maybe a fuse?

car is a 159 jtdm

jonnoj is offline  
Sponsored Links
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: Problem with 159 rear elec windows

My first thought was a fuse.
Fraser is offline  
Status: -
AO Member
jdrrco's Avatar
Join Date: Jan 2008
Location: United Kingdom
County: Monmouthshire
Posts: 358

Member car:

159 JTDm Qtronic

Re: Problem with 159 rear elec windows

^ what Fraser said... ^
jdrrco is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , elec , problem , rear , windows

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome