Brera Wiper Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-01-08 Thread Starter
Status: -
AO Member
gingah's Avatar
Join Date: Jan 2008
Location: Berkshire, UK
Posts: 12
Help Brera Wiper Problem

I have this intermittent issue, I had it about 2 weeks ago and then it went away but today I had it again. Last time I actually forgot about it and then the next time I needed wipers they just worked and have been working ever since.

Basically if I move the wiper arm down to intermittent, normal or fast, nothing happens.

If I push the wiper arm up to the "on demand" wiper posistion it gives me a wipe if I push and let go of it, so generally today I had to hold that arm up so I could see in the pouring rain.

If I pull the wiper arm towards me the windscreen washer jets squirt and the wipers do their usual 5 or s wipes then a pause then the final wipe.

Anyone else with the same or a suggestion?
gingah is offline  
Sponsored Links
Status: -
AO Silver Member
Mr-T's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: Durham
Posts: 1,415

Member car:

Citroen DS3

Re: Brera Wiper Problem

Only suggestion I have is that it's a fault that needs to be checked out.

And, at this time of year, urgently!
Mr-T is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , problem , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome