Number plate lights not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 02-10-16 Thread Starter
Status: -
AO Member
 
Join Date: Dec 2012
Location: United Kingdom
County: -
Posts: 99
Number plate lights not working

Could somebody direct me to the fuse for the rear bumper number plate lights please? Any other things to check for? Neither light is working, I've replaced one bulb & still no good.
davej311 is offline  
Sponsored Links
Advertisement
 
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
 
giblets46's Avatar
 
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,315
Garage
Check for corrosion as well!
giblets46 is offline  
(Post Link) post #3 of 6 Old 03-10-16 Thread Starter
Status: -
AO Member
 
Join Date: Dec 2012
Location: United Kingdom
County: -
Posts: 99
Quote:
Originally Posted by giblets46 View Post
Check for corrosion as well!
Thanks, any idea how I can find out which is the relevant fuse?
davej311 is offline  
 
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
 
giblets46's Avatar
 
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,315
Garage
Quote:
Originally Posted by davej311 View Post
Thanks, any idea how I can find out which is the relevant fuse?
tried the owner handbook? If no specifically mentioned it may be shared, in which case unless you have other issues with lights, it's probably a wiring issue.
giblets46 is offline  
(Post Link) post #5 of 6 Old 03-10-16 Thread Starter
Status: -
AO Member
 
Join Date: Dec 2012
Location: United Kingdom
County: -
Posts: 99
Quote:
Originally Posted by giblets46 View Post
tried the owner handbook? If no specifically mentioned it may be shared, in which case unless you have other issues with lights, it's probably a wiring issue.
Yes I guess so. Thanks
davej311 is offline  
Status: Workshop Controller
AO Silver Member
 
Mito_No3's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,089
Images: 12
No fuses power comes straight from the body computer
Mito_No3 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
lights , number , plate , working

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome