159 window closing problem after regulator fix - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 4 Weeks Ago Thread Starter
Status: -
jesujee's Avatar
Join Date: Sep 2016
County: -
Posts: 1
159 window closing problem after regulator fix


I have 159 2.2 JTS 2006 and yesterday I changed new window regulator to rear left. Took some 60 minutes for first timer and everything ok BUT... window won't go fully up. It goes almost until the end but stops just inside the sealing. Gives me some wooooosh at high speeds.

I already did soft reset for pressing window button 10 seconds down and up and also disconnected battery for 10 minutes. Did also make sure the upper sealing is fine... Still no good.

Do I have to open the door panel again and somehow adjust the motor..?

Help or tips anyone before I start it all over again.

jesujee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , closing , fix , problem , regulator , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome