wooshing from turbo and smoke - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 4 Weeks Ago Thread Starter
Status: -
Join Date: Aug 2016
County: -
Posts: 6
wooshing from turbo and smoke

Hello. Not long ago i had a split in the rubber pipe that goes to turbo (sorry i dont know mich about those things). The mechanic didnt have the pipe so he just put a metal cover on it and said it should be fine.

Last week i noticed when i accelerate hard and turbo starts working it makes a loud woooshhing noise. Also theres smoke.

No engine light on, maybe slight lose in power and higher diesel consumption.

Has the split on the rubber pipe got bigger opened up? Or any other possible cause?

Thanks for help
kamildasz is offline  
Sponsored Links
(Post Link) post #2 of 2 Old 4 Weeks Ago
Status: -
AO Member
Join Date: Aug 2015
County: -
Posts: 25
Replace it. Nuf said.
trcXL is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

smoke , turbo , wooshing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome