159 Starting and running problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
XoRacst's Avatar
Join Date: Jun 2014
Location: South Africa
County: Gauteng
Posts: 10
Hmmm 159 Starting and running problem


I tried checking through the forum but i never found a thread that had these problems. Wonder if there is anyone that can help me with this issue. I recently bought a 159 1.9 JTS 2007, had no issues. Then the problems started coming. The car suffers to start. I have to crank the engine 20 times before it starts, (starts instantly when engine is warm), the rough starting i can somewhat handle. The car lost somewhat power and apart from power does not rev. The rev suffering seems to be load related, when in first gear the engine revs to 4000rpm, in second the car revs till about 3000-3500, in 3rd the car revs 3000 and 4th the car revs 2000. The issue feels like the engine is not getting fuel (misfires and feels like there is a limiter in place).

We replaced the coil pack (after replacing the coil pack, which was not working on chamber 3 (no spark) we went for a drive and the car felt great. No problems and then after shutting the car off, starting it and going for a drive to the shops the car started having rev problems), spark plugs, fuel pump and fuel regulator. I took the battery terminals off and mounted them properly onto the battery. Unplugged the MAF and went for a drive, no changes. I also plugged in our diagnostics tool but did not find anything (apart from lights on the body computer). I am going to test the lambda and cam sensor today although i doubt that i will find the problem there since the engine light is not on.

Please if there is anyone with any information on this that can help i would appreciate it very much.
XoRacst is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome