How long should a crankshaft pulley last? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 22-09-16 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2016
County: -
Posts: 1
How long should a crankshaft pulley last?

So about two years ago I took my 159 2.4 to a local specialist for a cam belt service. An hour after getting it home the crankshaft pulley broke and the aux belt detached. Took it back the next day and 250 to sort it.

Yesterday I took it in to the same place for an oil service. An hour after getting it home it looks like the exact same thing has happened again.

Is this normal guys? Seems crazy
jdp86 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Dec 2009
Location: Netherlands
County: Zuid Holland
Posts: 213
To short aux belt fitted?
Jerry 159 is offline  
Status: -
AO Member
 
Norph's Avatar
 
Join Date: May 2015
Location: Buckinghamshire
County: United Kingdom
Posts: 111
Garage

Member car:

159 SW Ti 2.4

That isn't right. I agree with Jerry; they should last 70k ish.

Sent from my HTC One_M8 using Tapatalk
Norph is offline  
 
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 42,282
They should last 70k ish, trouble is when you buy a new one its not a new one, its one that has been sitting on a shelf in a FGP warehouse for ten years. Does sound unusual that they have failed both times very shortly after being at a garage, especially as you don't go anywhere near one when doing an oil & filter change.
Pud237 is offline  
Status: -
AO Member
 
nogrip's Avatar
 
Join Date: Jul 2016
County: -
Posts: 157
May be a faulty tensioner?
nogrip is offline  
Status: -
AO Gold Member
 
MalcQV's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,803
Images: 27
Garage

Member car:

159 2.4 JTDm

Quote:
Originally Posted by jdp86 View Post
So about two years ago I took my 159 2.4 to a local specialist for a cam belt service. An hour after getting it home the crankshaft pulley broke and the aux belt detached. Took it back the next day and 250 to sort it.

Yesterday I took it in to the same place for an oil service. An hour after getting it home it looks like the exact same thing has happened again.

Is this normal guys? Seems crazy
Seems a bit short. I'd be a bit annoyed.
MalcQV is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
crankshaft , long , pulley

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome