06 159 Cd Player issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 05-09-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2010
Location: United Kingdom
County: Glasgow
Posts: 12
Images: 2

Member car:

Alfa 159 1.9 JTS

06 159 Cd Player issues

Evening all,

I tried to swap my older 06 factory version stereo with no audio button on my 159 for a newer factory version with audio button in an attempt to have AUX input.

After trying the new head unit there was no power at all and considering how it was delivered I assume it's DOA.

Downside is when replacing with the old original unit I now have no life (no illumination or use of buttons eject etc etc.) in the facia apart from power. I still have use of the steering wheel buttons though...

Has anyone experienced this before or any ideas why it might be happening? I am by no means an ICE specialist and though possibly wrongly that this would be a straight swap!

Cheers in advance!
Acid89 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , issues , player

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome