Alfa romeo 159 power steering problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-09-16 Thread Starter
Status: sad
Join Date: Sep 2014
Location: Croatia
County: -
Posts: 6
Alfa romeo 159 power steering problem

Hello guys i have simular problems like few of you here.

Servo on place is very hard and scraping.

I changed oil tutela gi/r - green
Flush complete system with new oil.
Reservoair is black and year on it is 10. So i think is changed by last owner.

I have feeling that in morning when car is standing over night power steering is easyer, but on few kilometars etc. 10-15. its the same.
jurek_purek is offline  
Sponsored Links
Status: major trauma
AO Silver Member
stan laurel's Avatar
Join Date: Sep 2012
Location: United Kingdom
County: Lancashire
Posts: 2,989
It sounds like the power steering pump is failing.

I can't think of any other reason, sorry
stan laurel is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , power , problem , romeo , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome