Brera 2.4 jtdm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 7Likes
  • 1 Post By MalcQV
  • 2 Post By Chipmik
  • 1 Post By OldSmokey159
  • 1 Post By Chipmik
  • 2 Post By Rewe
 
Thread Tools
jey.d.
Status: - Update
Guest
 
County: -
Posts: n/a
Brera 2.4 jtdm

Hello everybody. Couple of days ago i bought a 2.4 jtdm brera, which has been a dream of mine. I did know there were some issues though concerning the powersteering, making extreme noise when steering left-right. However, the previous owner said that with the part he ordered which was some sort of power steering related huge tube, the problem would be resolved. Obviously it was not. From what the mechanic said the powersteering pump has to be replaced. I would like to ask if indeed this should fix the issue or whether will appear again? And also i would like your advice on maintaining affordably a brera. Thank you
 
Sponsored Links
Advertisement
 
Status: -
AO Platinum Member
 
MalcQV's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 12,062
Images: 24
Garage

Member car:

Office Chair.

I think it is more to do with the type of power steering fluid used. Plenty of threads on it . Mine has made a bit of noise since I bought it.

I'm just waiting for it to break You can I believe empty it out and replace with the correct fluid whatever that might be but it depends which way the moon is facing when the sun collides with Pluto.
jey.d. likes this.
MalcQV is offline  
Status: -
AO Member
 
Chipmik's Avatar
 
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 619
Garage

Member car:

159 2,4 JTDm 210

You should look into your powersteering resevoir..There might be a filter floating around in it, if so you need a new resevoir (Known issue)
MalcQV and jey.d. like this.
Chipmik is offline  
 
Status: -
AO Member
 
OldSmokey159's Avatar
 
Join Date: Mar 2016
County: -kent
Posts: 250
Take the cap off the resivoir, fluid should be a bright green colour (not red). If it's red it needs to be replaced (with green - tutela automatic transmission fluid).

If fluid in the resivoir is frothing whist the motor is running then Changing the fluid and cleaning the resivoir will likely help unless of course damage is advanced by use of incorrect fluid.
jey.d. likes this.
OldSmokey159 is offline  
jey.d.
Status: - Update
Guest
 
County: -
Posts: n/a
Thanks a lot guys for your help. It is much appreciated.


Sent from my iPhone using Tapatalk
 
jey.d.
Status: - Update
Guest
 
County: -
Posts: n/a
One last thing. How much should i expect for the price range of the power steering pump to be? And also is it acceptable to drive the car a bit? Or should be avoided at all costs?


Sent from my iPhone using Tapatalk
 
Status: -
AO Member
 
Chipmik's Avatar
 
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 619
Garage

Member car:

159 2,4 JTDm 210

Why do you absolutely think the pump is dead when theres a lot of cheap other fault possibilities...There is a well known issue with earlie tanks with filter getting loose & doing exactly like you described..Have you checked the level at all?
Chipmik is offline  
jey.d.
Status: - Update
Guest
 
County: -
Posts: n/a
The mechanic who checked it said so. Might be a chance that he is trying to rip me off but i cannot prove it. I will take it to another guy though tomorrow. Hopefully, they might be able to give a clear answer to what's up and how to be fixed. In the meantime, should it be driven (logically does not make sense) or it might be too risky?


Sent from my iPhone using Tapatalk
 
Status: -
AO Member
 
Chipmik's Avatar
 
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 619
Garage

Member car:

159 2,4 JTDm 210

If hes used to Alfas, id say he probably right, if not..Have a quick look in the tank first ;-)...& honestly...I missed out the last piece you wrote about the mechanic, so totally sorry bout that :-)

Kfz Ersatzteile Suchen

Gives an indication of the cheaper part of prices from the net if you could DIY :-)
jey.d. likes this.
Chipmik is offline  
Status: -
AO Silver Member
 
Rewe's Avatar
 
Join Date: Apr 2011
Location: United Kingdom
County: Norfolk
Posts: 1,154

Member car:

Brera

Quote:
Originally Posted by OldSmokey159 View Post
Take the cap off the resivoir, fluid should be a bright green colour (not red). If it's red it needs to be replaced (with green - tutela automatic transmission fluid).

If fluid in the resivoir is frothing whist the motor is running then Changing the fluid and cleaning the resivoir will likely help unless of course damage is advanced by use of incorrect fluid.
If the fluid in the reservoir is frothing than that is likely to have been caused by the filter coming loose and cleaning won't help. A new reservoir won't break the bank. I'm going to go against the grain though and suggest that if the seals in your rack have coped happily with red fluid all these years then you are safer to leave it in.
Chipmik and jey.d. like this.
Rewe is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
brera , jtdm

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome