Help with error code P1714 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-08-16 Thread Starter
Status: -
AO Member
cskals's Avatar
Join Date: Apr 2013
Location: Denmark
County: Fyn
Posts: 50

Member car:

159 2.4 JTDM

Help with error code P1714

Hi all.
My 159 Q-tronic has this error code P1714.
I've deleted it, but it keeps coming back, the car can't shift gears and some electric faults starts as soon as the error appears.
I think it's an electric fault on the gearbox, hopefully from the plug and nothing more serious than that.
But how do I check/fix it? Maybe a picture of the plug and where it's located since I have no idea where to start looking.
Attached Images
File Type: jpg Udklip.jpg (70.3 KB, 11 views)
cskals is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2016
County: -
Posts: 99
You need to know what the fault code reads, but other than that you may just need a software update
Clay19 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

code , error , p1714

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome