Diagnostic fault codes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 10-08-16 Thread Starter
Status: -
AO Member
 
Ti84's Avatar
 
Join Date: Aug 2016
Location: North Lincolnshire
County: United Kingdom
Posts: 11
Garage

Member car:

159 1.9 JTDm TI

Hmmm Diagnostic fault codes

Hi All

Bought my 159 1.9jtd TI on Friday, has a full service history; last full service in April.
For my piece of mind i decided to get an interim service from kwickfit, for a full service i will be taking to an alfa specialist (Does anyone know a good one in the North Lincolnshire area?).
Back to the issue, kwikfit has carried out a diagnostic on the car and come up with the following fault codes:-

P2009 Swirl Flap Power Supply (Does that mean that they have been removed from the plastic inlet manifold, I was thinking of doing this if they still on the car).

P0380 Glow Duration control Open Circuit

Could anybody shine some light on the matter, any info will be greatly appreciated

Also it does sound a bit rough on cold starts but that disappears by the time i get to the end of my road about 100 meters.


Thanks Tino.

Last edited by Ti84; 21-08-16 at 12:25. Reason: Just added a video to see if anyone can help
Ti84 is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 2 Old 05-04-17 Thread Starter
Status: -
AO Member
 
Ti84's Avatar
 
Join Date: Aug 2016
Location: North Lincolnshire
County: United Kingdom
Posts: 11
Garage

Member car:

159 1.9 JTDm TI

Hi everyone, been to busy to post a reply, got the Alfa sorted back in December ended up changing the inlet manifold, GJ Automotive in Lincoln (who was owned by Gary) carried out the work (just recently bought out by Mid Lincs Test Centre, Gary works for them now) the car has been running brilliantly since, had a full service and MOT with no advisories ? done yesterday by Mid Lincs.

Let's hope I will have many more years of happy motoring with the 159!!! Until I can afford that beautiful Gulia ?.
Ti84 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
codes , diagnostic , fault

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome