Spider 2.4 jtdm misfire etc - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 01-08-16 Thread Starter
Status: -
AO Member
 
Join Date: Jul 2010
Location: United Kingdom
County: Norfolk
Posts: 34
Images: 6
Spider 2.4 jtdm misfire etc

Hi,
Grateful for any help, 2007 Spider 2.4 jtdm has a really lumpy start up, sometimes stalling and a misfire at low throttle openings which is usually present but occasionally clears and the car becomes smooth and powerful. So far she has a brand new Bosch maf and a cheaper map sensor. I have blanked off the egr with a partial restrictor and cleaned the throttle valve and egr ports. I have put industrial quantities of injector cleaner tbrough 5 tanks of BP Ultimate. I have no fault codes showing but as she settles on the idle and the misfire comes in, the correction codes on cyls 4 and 5 go to about 2.8 and 3.4 respectively, all the others remain within 2. Is it time to have the injectors pulled or is this a red herring?
Tobenn is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
nogrip's Avatar
 
Join Date: Jul 2016
County: -
Posts: 157
Leaking swirl flaps will cause the lumpy startup. If your're brave then a temporary seal could be made around them to then check the lumpy idle and injector correction values. It would be better to do the SF's properly though.
nogrip is online now  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
jtdm , misfire , spider

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome