20v coolant lost - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 29-07-16 Thread Starter
Status: -
AO Silver Member
 
Cream's Avatar
 
Join Date: Mar 2002
Location: wrexham
Posts: 1,324
Images: 2

Member car:

Brera 2.4SV

20v coolant lost

sitting in a que tonight and sudden see wisps of coolant vapour

when i stopped the front of the engine was covered in coolant and there was nothing in the coolant bottle and no pressure !

on the front of the engine is a coolant rail and it looks like a pressure blow off valve has, well... blown

managed to get the car home but has anyone else had to fix this ? can i just block it up with a screw and some glue ?
Attached Images
File Type: jpg b1.jpg (100.7 KB, 14 views)
File Type: jpg b2.jpg (165.2 KB, 14 views)
Cream is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
nogrip's Avatar
 
Join Date: Jul 2016
County: -
Posts: 161
Well known weak point - the plastic air bleed valve is cr*p. A metal upgrade is available.
nogrip is offline  
Status: -
AO Member
 
GroovyBoovy's Avatar
 
Join Date: Jan 2011
Location: United Kingdom
County: Durham
Posts: 333
Images: 2
Its probably the bleed screw. Carnt remember whats its made of, but on mine they had to remove the rail to drill it out and replace. A bit of a design fault. Its under a bit of presure so you probably carnt get away with glue.
Rob
GroovyBoovy is offline  
 
(Post Link) post #4 of 7 Old 29-07-16 Thread Starter
Status: -
AO Silver Member
 
Cream's Avatar
 
Join Date: Mar 2002
Location: wrexham
Posts: 1,324
Images: 2

Member car:

Brera 2.4SV

cheers guys, will have a look for the part number
Cream is offline  
Status: -
AO Member
 
Chipmik's Avatar
 
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 551
Garage

Member car:

159 2,4 JTDm 210

Here you go :-)
Chipmik is offline  
Status: -
AO Member
 
Chipmik's Avatar
 
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 551
Garage

Member car:

159 2,4 JTDm 210

Helps to remember attachement
Attached Images
File Type: jpg IMG_20160731_142725.jpg (75.2 KB, 8 views)
Chipmik is offline  
(Post Link) post #7 of 7 Old 02-08-16 Thread Starter
Status: -
AO Silver Member
 
Cream's Avatar
 
Join Date: Mar 2002
Location: wrexham
Posts: 1,324
Images: 2

Member car:

Brera 2.4SV

many thanks
Cream is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
20v , coolant , lost

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome