Gauge Light Gone - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-07-16 Thread Starter
Status: Lovin my 159 :)
AO Member
 
AiducoQV's Avatar
 
Join Date: Sep 2011
Location: Slovakia
County: Bratislava
Images: 10
Gauge Light Gone

Hello friends,

I guess there is surely a thread about this but I am somehow unable to find it. Anyway, can anybody help me how can I change the light in my speedometer on the instrument cluster panel?
I noticed that the needle on speedometer is not flashing as the rest of the speedometer.

The problem is that I have no idea how to open and access and remove the speedometer itself, and if there are bulbs or LEDs, and even if those LEDs/bulbs can be changed. Or am I supposed to order new instrument cluster?

I am adding the picture: https://drive.google.com/file/d/0B0l...ew?usp=sharing

Many thanks!!
AiducoQV is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 2 Old 25-07-16 Thread Starter
Status: Lovin my 159 :)
AO Member
 
AiducoQV's Avatar
 
Join Date: Sep 2011
Location: Slovakia
County: Bratislava
Images: 10
Really? No asnwers?
AiducoQV is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
cluster , light , needle , speedometer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome