DOH! have i just screwed it up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-07-16 Thread Starter
Status: -
AO Member
sketchy19's Avatar
Join Date: Aug 2013
Location: UK
County: South East
Posts: 83
DOH! have i just screwed it up

So Following a few other issue i decided to clean my MAP sensor (2.0 jtdm 170)

This turned out to be a good move as it was completely blocked with crap. BUT, while carefully removing the senor (apparently not carefully enough) I snapped the clip on the back/bottom of the sensor that holds it in place along with the bolt.

Is this going to be problem eg. boost leak. If yes is it a new manifold?

sketchy19 is offline  
Sponsored Links
Status: Inspired
AO Gold Member
Verbout's Avatar
Join Date: Feb 2014
Location: United Kingdom
County: West Yorkshire
Posts: 8,775
Images: 11
They're usually a tight fit, can you fashion some tie wraps to hold it in place?
Verbout is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

doh , screwed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome