Broken top radiator mounts (Brera 2.4) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 12-07-16 Thread Starter
Status: -
AO Member
 
Monty66's Avatar
 
Join Date: Mar 2016
County: -
Posts: 124
Broken top radiator mounts (Brera 2.4)

Was giving the engine bay a bit of a clean at the weekend, and realised the radiator seemed to move a little.

On closer inspection, it seems both plastic pegs have sheared off and the previous owner and just attempted to glue them back on (Tw**!).

Can new pegs be bought? Is this a common issue with Brera radiators? Will I need a new radiator or will it be fine just on the bottom mounts?

Thanks
Monty66 is offline  
Sponsored Links
Advertisement
 
Status: Still engineering
AO Silver Member
 
Old Engineer's Avatar
 
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 2,093
Images: 12
Poor accident repair.
Old Engineer is offline  
(Post Link) post #3 of 6 Old 12-07-16 Thread Starter
Status: -
AO Member
 
Monty66's Avatar
 
Join Date: Mar 2016
County: -
Posts: 124
There are zero signs that the front end has had an accident, any positive suggestions out there on how to remedy this?
Monty66 is offline  
 
Status: Still engineering
AO Silver Member
 
Old Engineer's Avatar
 
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 2,093
Images: 12
Old Engineer is offline  
(Post Link) post #5 of 6 Old 12-07-16 Thread Starter
Status: -
AO Member
 
Monty66's Avatar
 
Join Date: Mar 2016
County: -
Posts: 124
I think the main question here is "Do I have to replace the entire radiator?" It is absolutely fine, I am loathed to spend money on a new one if there is an easy fix to prevent it moving.
Monty66 is offline  
Status: Still engineering
AO Silver Member
 
Old Engineer's Avatar
 
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 2,093
Images: 12
Compare what you have with the parts for sale in the first link and see if it is this peg or further in.
Old Engineer is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
brera , broken , mounts , radiator , top

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome