Occasional engine cut out 2.0 8v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-04-16 Thread Starter
Status: endlessly busy doing nothing
AO Member
thyssenkrupp's Avatar
Join Date: Sep 2013
Location: Norway
County: Oslo
Posts: 97
Unhappy Occasional engine cut out 2.0 8v

Hello fellow 155 owners
This issue with my good ol' 155 has been going on for a few weeks now.

The problem:

Usually happens at light throttle, the engine cuts out while cruising or creeping in traffic, seems like ignition related (as if it was shut off for a brief moment). At low speeds this issue will cause a violent jerk (especially in 1st or 2nd) while in 5th, it naturally feels less violent. This is driving me insane, my better half now refuses to drive the 155 (because its "scary" )

Here are things that I tried so far:

Now this is my 4th 155 with the 8v 2.0, so I am very familiar with bits and pieces of the engine, I am no mechanic by all means but I get things done. Crank pos. sensor is 1yr old, O2 has been changed, has gone over all the connectors 2 years ago when I had the intake plenum off the car due to other problems (false air coming in) the ICV valve and the MAF are also changed, I have like three of each laying in the trunk, JUST IN CASE, along with a whole bunch of other crap. It does not look like a bad ground as everything else stays "on" lights, radio and etc.

So gents and lads, what can this be? Give me some pointers before my neck snaps off in traffic, I will also change the HT leads next week, I think....


T. Starheim
thyssenkrupp is online now  
Sponsored Links
Status: Have another Alfa
AO Gold Member
wayne-dear's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Merseyside
Posts: 10,132
My 8v cuts out now and again, does not 'jerk' though, likes to suddenly not start as well when it has been running perfectly, traced mine to fuel pump relay, I carry a fused lead in the boot to give me a direct live.
wayne-dear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

cut , engine , occasional

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome