Fuel pump relay advice . . - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-11-07 Thread Starter
Status: -
AO Member
timmy c's Avatar
Join Date: Jul 2007
Location: Dorset. Ooh Aar.
Posts: 19

Member car:

155 2.0 16v

Fuel pump relay advice . .

Hello everyone -
I've had my P-reg 155 2.0 16v TS since July with no major problems, and loving the car in general but I've come across something I need some advice about. .
And you lot seem to know your stuff !

So a week or two after I bought the car, on a couple of occasions it wouldn't start, spluttering & wouldn't pick up off the starter like there wasn't enough fuel going in. I took out the 4 relays in the little boxes around the battery, cleaned the contacts (they looked dirty) and its started first time, every time since. But read on . .
Well I was driving in some extremely inhospitable weather condition on Monday morning, including some very deep puddles. All was well, didn't drive it until this morning (Wednesday), now every time I go over a bump the injection warning light flashes on the dash and it hesitates guite badly under throttle (sometimes. It seems to happen randomly).
I'm guessing its probably something to do with the relays, maybe getting wet or maybe just decided to give up now.

So my questions are as follows -
Which relays do what, theres 2 in a little box with 2 fuses, directly to the left of the battery, and 2 in a little box directly in front. They appear to all be the same?

And has anybody else had problems like this? Is this the likely cause?
(The relays themselves all look like they've been in the car since new, so its entirely possible that one of thems given up)

And finally, where is the fuel pump ? (Just so I can check the contacts on that too.)

Thanks in advance, and sorry about the mega-post, just want to give you all the info !

Cheers, Timmy x
timmy c is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

advice , fuel , pump , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome