155 2.0 16v starter runs after ignition turned off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-01-07 Thread Starter
Status: -
Join Date: May 2006
Posts: 2
155 2.0 16v starter runs after ignition turned off

I noticed my car was making a weird whirring noise just before I turned it off tonight. After I turned it off I noticed that the wirring continued (key out of ignition). It lasted for about 20 seconds and then stopped. Followed by burning plastic smell.

I tried to restart it and not even a click of the starter relay - dash lights on but otherwise dead.

Left it for half an hour and on my return it started first time. I turned it off and the whirring again continued. Open the bonnet and to my dismay I could see an orange glowing spark from behind the engine near the passenger footwell!

After the whirring stopped I ventured inside to find a torch - the +ve cable on what looks to be the starter has some melted shielding around where it joins the starter. I assume as the only thing that is +ve when the ignition is off is the main feed to the starter circuit it was the starter that was wirring once the engine was turned off but I can't fathom out why the starter would be engaged after the engine has been turned off?

Any ideas?

reddevil is offline  
Sponsored Links
Status: playing kill by numbers
AO Gold Member
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 7,716
Re: 155 2.0 16v starter runs after ignition turned off

starter relay sticking?
Cuore_Sportivo_155 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

155 , 16v , ignition , runs , starter , turned

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome