I've broken an Eibach spring!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-04-06 Thread Starter
Status: -
AO Member
Join Date: Nov 2002
Location: maidstone, kent
Posts: 117
I've broken an Eibach spring!!


I have a broken Eibach sping on the tail of my 155 8V. Eichbach only sell them in fours, and I'm not shelling out 's for another set of 4 when I only need one of them...
I've noticed a set of 4 made by Vogtland on ebay around the 80 quid mark, which sounds a whole lot more reasonable. I was thinking I would maybe buy a set and use the rear two...
Alternately, if somone has two matching rear springs (lowered), or alternately a single rear Eibach from the 155 handling kit that they want to move on for a small amount of cash, please let me know. At the moment I'm running one Eibach and one standard, which gives it rather strange high speed stability....




black 20 TS
dunc is offline  
Sponsored Links
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Re: I've broken an Eibach spring!!

I presume when you say you "broke" it you don't mean you took it off the car and beat it with a lump hammer...?

If it broke under normal conditions, it sounds like it was faulty. Won't Eibach give you a new spring, under warranty?

Ralf S.
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

broken , eibach , spring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome