dianostics - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-12-05 Thread Starter
Status: -
AO Member
Join Date: Apr 2005
Location: weston, somerset
Posts: 48
Help dianostics

right my car failed emissions on mot so i just had a simple dianostics done on it not testin the ecu, but 2 faults came up the lamda sensor reading and the lamda sensor had a short to earth. so i just had a new lamda fitted is there anythin i need to do other than plug it in. the injector light still comes on for about 5 seconds after its started, is there any way i can reset the ecu and check the ecu for faults?

jama665 is offline  
Sponsored Links
Status: PSN ID: Jack155Q4
AO Gold Member
AlfaJack's Avatar
Join Date: May 2003
Location: United Kingdom
County: Kent
Posts: 6,825
Images: 4

Member car:

1993 Alfa 155 Q4

Re: dianostics

plugging it in is all you need to do

you can try resetting the ecu by leaving the battery disconnected for about 30mins I think.

how badly did it fail? 5 seconds is a bit too long, should only be 1 or 2,

My usual way is to dump a load of redex injector cleaner in and give it a hell of a razz
AlfaJack is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome