heater probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
heater probs

Can anyone help i have a 1996 155 1.8 16v ts great car but i have no heater and iam frozen.I have had the dash out and all the cables are connected i have checked the fuses and all seems fine,anybody got any ideas??????????
Sponsored Links
Status: PSN ID: Jack155Q4
AO Gold Member
AlfaJack's Avatar
Join Date: May 2003
Location: United Kingdom
County: Kent
Posts: 6,825
Images: 4

Member car:

1993 Alfa 155 Q4

Re: heater probs

Hi, welcome to AO

Does the fan fun at all?
AlfaJack is offline  
Status: - Update
Posts: n/a
Re: heater probs

Hi, I have this problem on my v6 climate contolled heater .. turned out to be a bad connection at the fan ( above the passenger footwell,under the glove box give the connector a wriggle and see... great cars shame about the electrics...
Status: - Update
Posts: n/a
Re: heater probs

Same as above....does the fan work. Can you describe what else is going on, do you have knobs to turn or buttons to press on the panel?

Could be one of a few things....electric panel nakkered, fan dead, thermal resister packed up, water tap gone, glitch in the matrix etc etc

Welcome btw

Status: - Update
Posts: n/a
Re: heater probs

dont forget that stupid lever that snaps off but stays in-situ

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

heater , probs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome