Oil pressure gauge/sending unit - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Help Oil pressure gauge/sending unit

Back again folks. My oil gauge started doing funny things the other day. It would indicate good pressure then just drop to 0, and not slowly like pressure was going down just a instant drop to 0 and stay there. Are the sending units on these motors prone to act up? I am having my tensioner replaced as I can not tighten the chain using the method decribed in a earlier thread. Will replace the sending unit as well. The oil light does not come on when the gauge jumps to 0 and the car is running fine. Any one out there have similar problems? One last question, do these cars have grounding problems like my saab? Thanks again. Bill
Sponsored Links
Status: - Update
Posts: n/a
Re: Oil pressure gauge/sending unit

Hi Bill

Oil sending units have been known to give problems on one or two but not all. As for grounds, not really but they do suffer from corroded connections anywhere just like most cars

Unable to tighten your chain...no idea, sorry.

Status: - Update
Posts: n/a
Re: Oil pressure gauge/sending unit

My oil pressure sender went and it just read low all the time (ie 2 bar max !!!).
It's easy to change, it just screws off. It's positioned behind cylinder number 4 and looks kinda like an egg cup.

Chain tension. Are you sure it's the chain that's rattling then ???
The tensioner is just a pulley on a spring which takes up the slack in the chain. Nothing to break really unless the spring has snapped. To change this, the head will have to come off. You can change the spring by itself by undoing the huge Allen bolt at the back of cylinder number 1. The spring will move the tensioner about 2 inches in total so I think you have another problem (maybe super stretched chain ???) unless of course the tensioner has "stuck" in position. That's unlikely though as it'll be covered in oil.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

gauge or sending , oil , pressure , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome