Exhausted - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-11-04 Thread Starter
Status: -
AO Silver Member
Phil's Avatar
Join Date: Aug 2002
Location: United Kingdom
County: East Sussex
Posts: 1,150

Just had the new Ragazzon stainless exhaust fitted minus a centre box, it's not very loud at all just a nicer tone (thanks for the tip MT). On Saturday I also got round to fitting the 145 intake pipe to replace the masses of black plastic boxes on the 155. I already had a K & N panel filter fitted. Have only done a bout 15 miles and already it feels a lot more responsive in the mid range but I have'nt really revved it so no comment yet. I'm sure from others comments that things shoulod improve after a few more miules when the ecu learns its new settings or whatever. Even now though I am very happy with the set up.


It was once said that the meek shall inherit the Earth, I have since discovered that the meek don't want it.
Phil is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome