Common Problems in the 155 - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Mooney Re: Common Problems in the 155

Common problem, you need a 75!, I owned a 75, sold it for a 155 (big mistake), sold the 155 and bought another 75 3.0 V6 (eats 155's for breakfast)

Only problem is you can walk without a limp after driving a 155! (any 75 owners will testify to this)

Sell the 155, buy a real alfa!

Only joking, 155 is a great car, fun, fast, enjoyable

Just prefer the 75 for fun driving (couldn't drive a 75 every day though)

Enjoy your 155
Sponsored Links
Status: -
AO Member
Mixsynth's Avatar
Join Date: Aug 2002
Location: Peterborough UK
Posts: 42

Member car:

147 2.0 Lusso

Re: Common Problems in the 155

Whaat?? The 75 was one of the ugliest Alfas ever produced. Sure, it may have been built before Fiat owned them, it may have rear wheel drive and it may have that "unique" U-shaped handbrake... but it looks ugly as sin compared to the 155

Only teasin, I'm sure it's great to drive.... I suppose the best place to be is behind the wheel, so you don't ever have to look at it

Mixsynth is offline  
Status: - Update
Posts: n/a
Re: Common Problems in the 155

i don't think the 75 is that that ugly..there's something about the pre-fiat alfa's that is appealing...maybe its they're "beasty" look...but to b frank i think the coolest ever models from alfa have been the Old gtv's, the montreal the BZ and the 155...
Status: - Update
Posts: n/a
Re: Common Problems in the 155

I had a 75 2.0TS prior to the 155 and loved it.
Would love to get a 3.0V6.
Status: - Update
Posts: n/a
Re: Common Problems in the 155

well Stallion, we can laugh at the 16v owners as the 8v is the all alluminium Alfa engine (16v has bits of iron somewhere), and the V6 is also an all alluminium Alfa engine. I had a 2.0litre TS 75 for a very short while. It sounded a better than my TS 155 Silverstone, but I don't think it handled nearly as well. Forget the RWD thing, it just couldn't corner as well as the 155 and the brakes were terrible, despite just being recently overhauled with new everything. Oh... and 2nd gear crunched every time you engaged making fast getaways nearly impossible as you waited for the synchro to catch up

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

155 , common , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome