Variator vibrations? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-05-04 Thread Starter
Status: -
Join Date: Jan 2003
Location: South Africa
Posts: 9
Help Variator vibrations?

Hi guys!

I have a -95 155 2.0 TS 16V and I have owned it for almost two years now and it have been a plasure all the time. It has 181k on the clock and I have driven it 80k in less than two years and haven't had any expenses with it so far other than regular services. I drive it back and forth to work 200 km every day and I wouldn't have another car.

But a few days ago I noticed that the car started making excessive noice when I revved it above 4500 rpms and it also started to make some high pitched vibrations. At the same time it also felt like it lost it's power. Still it idles nice and no extra noice is heard (apart from a little diesel clatter from the variator when I start the car half warm, newer at cold starts or if I start it again within 10 minutes).

At first i suspected the engine mounts but they are ok. Then I changed the sparkplugs and checked the variator solenoid by pulling the cable of at approx. 2000 rpms and I noticed that the engine sound changed a little but still no change when I drove it. It still made these vibrations above 4000 rpms or so. Then I pushed it around a little harder and suddenly the vibrations disappeared and the engine behaved like should for a couple of days and then again the vibrations started.

I am pretty sure that it got something to do with the cam timing but is it the variator sticking or is it the solenoid sticking? I'm up for timing belt change now but it's expensive to have the shop to look for faults so I would like to know in advance what to look for so I don't end up changing anything unneccessary.


Kiepie is offline  
Sponsored Links
Nordic Blue
Status: - Update
Posts: n/a
Re: Variator vibrations?

they did an upgrade for the variator solenoid spring in a kit so i would go for that as it sounds like this spring is knackered and an oil/filter change.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

variator , vibrations

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome