Forced air ventilation (non-AC) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Forced air ventilation (non-AC)

I have the bog standard heater system in the 155. The fan speed dial has about a third of a turn before fan speed 1,2,3,4. There is meant to be forced air only into the cabin on this setting (no fan). I get nothing, and the switch only just goes past 1. It springs back if turned further anti-clockwise.

Someone suggested the pollen filter, so I checked whilst I was sorting out the juddery wipers last weekend. I haven't got one! Just a plastic cover over an intake flap. I assume that the AC models have one, whilst the heater only ones don't.

Anyway... The flap opens differing amounts depending on where the fan switch is (sort of makes sense), but is completely shut just past '1' on the dial, explaining the total lack of any forced air. I guess that the cable linking the flap to the dial isn't the right length, or needs adjusting. Is this normal? I couldn't see any way of doing it from the top, so I guess it needs to be done from the dash side. How difficult is it to remove the facia (without destroying it)? Shall I just live with it?

I've also noticed that ther is no recirculation option. I have to stop the ventilation completely if I'm following something smelly!

Sorry for the long post.


'97 2.0 16v
Sponsored Links
Status: - Update
Posts: n/a
Re: Forced air ventilation (non-AC)

Hi, my 155 is exactly the same as yours and has been since new, I have just assumed that there is no forced ventilation.
How successful was your wiper job?
Status: -
AO Member
Join Date: Dec 2001
Location: Sweden
Posts: 564
Idea Re: Forced air ventilation (non-AC)

Mine seems to be the same as yours perhaps it's because of the aerodynamics of the 155.
spiros54 is offline  
Status: - Update
Posts: n/a
Re: Forced air ventilation (non-AC)

Guess I'll just live with it.

Wiper motor contacts were full of grease. Wiped clean and refitted. Worked fine for a while, but judders a bit when returning now unless screen is very wet. Simple job really. I also repaired the washers at the same time (duff y-piece).

Only judders on return, and usually only on the first few cycles. It's fine on full speed, and if you keep the stalk pushed up whilst the wiper is moving. Problems only occur when the arm is returning to park. Probably an iffy contact or something.

It's not really a judder, it's just not as smooth as it should be. Many times better than it was before though!

Nordic Blue
Status: - Update
Posts: n/a
Re: Forced air ventilation (non-AC)

solution don't drive behind anything smelly.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

air , forced , nonac , ventilation

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome