Hazard lights - erratic behaviour - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hazard lights - erratic behaviour

Got a call in my office this morning - someone had spotted that my hazard lights were on in the car park. By the time I got out there they were no longer on. This happened a few weeks ago too but that time the lights were on when I got to the car - I chose to ignore the problem until it recurred...which is now.

Any ideas on this - anyone seen it before? Could it be alarm related, or a dodgy circuit or something? Don't know where to start looking
Sponsored Links
Status: -
AO Member
Join Date: Dec 2001
Location: Sweden
Posts: 564
Could be Alarm related, I've noticed that when the alarm is triggered the siren sounds's for about 30 seconds and switches off but the hazard lights continue, never looked into how long tho.
spiros54 is offline  
Nordic Blue
Status: - Update
Posts: n/a
Check for leaks in footwells and check to see if your fusebox is dry.
Status: - Update
Posts: n/a
Cheers guys. Can't find any dampness/leaks around the fusebox or in footwell, everything is dry. I'm fairly sure the alarm hadn't gone off (well, the noise bit of it anyway) because I would have heard it. Perhaps I should try setting it off on purpose and see what happens.
Status: - Update
Posts: n/a
I think it is the alarm and is supposed to do it. If your alarm has gone off, when you get to the car and turn the key the led should be flashing. Also I think the alarm makes a different noise when you disarm it after it has sounded. There was a thread on here b4 which states how you can interogate the alarm and find out why it sounded or where the fault is. It invloves pressing the bonnet alarm plunger switch.
Status: - Update
Posts: n/a
1 flash RH front door
2 flashes LH front door
3 flashes RH rear door
4 flashes LH rear door
5 flashes Ultrasonic sensors
6 flashes Bonnet
7 flashes Boot
8 flashes Key operated supply cut off
9 flashes Battery supply cut off
10 flashes 3 or more simultaneous alarms

You can also do a manual diagnosis as follows:
Open the bonnet and turn the ignition key from Marcia to Stop.
Within 15 seconds press the bonnet pin switch 7 times in less than 10 seconds.
You will hear 5 beeps and after 10 seconds the indicators will flash once.
The ultrasonics are now tested, if OK the indicators will flash 3 times and you will hear 3 beeps.
Now you can trigger each sensor in turn (doors/boot/bonnet)and if Ok each trigger will give a beep and a flash.
Turn the key to Marcia and you get a brief siren and the indicators will flash for 2.5 seconds. This operation will automatically exit the test mode, but you can also exit at any point by not triggering any sensor for 30 seconds, at which point the indicators will turn on for 2.5 seconds and a beep will sound


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

behaviour , erratic , hazard , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome