variator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a

I have 1,7 8v and its suffers from bad idlle most of time,...I tryed everything no cure..take out variator and noticed that metal piston inside are not closing compleately, its like 1,5 , 2mm open and its oil dirty...can that ceose problem...anyone...marlon?
Sponsored Links
Status: - Update
Posts: n/a
The variator doesn't affect the idle on the 8v engine (works differently to that of the 16v). The thing you've called the variator is actually the magnetic actuator. The variator is attached to the end of the inlet cam. If you think this is the problem, make sure the inside is clean and then put in a couple of drops of engine oil. Make sure the pin moves freely. It is unlikely that the length of travel has changed on this though.

I take it you've cleaned the air bypass valve. This is attached to the side of the intake manifold. Think it's held on with an Allen bolt and then pull it out. You will see a sliding mechanism in a "window". Make sure this is clean and moves freely. Also make sure you have no splits in the hose from this part to the main hose of the intake system. Also make sure the butterfly in the throttle housing is clean. This gets bunged with oil due to the crankcase ventilation system. Let us know how you get on.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome