Alarm fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
R Finnis
Status: - Update
Posts: n/a
Alarm fault

An age old problem from what I can gather! The alarm keeps going off at random times, usually in the middle of the night! I can be almost certain of it going off if it has been a warm day, and a cold evening (weird).

When it arms, it makes a long beep, followed by a short one, indicating a fault in the system. Is there a simple way of narrowing this down to a particular area? It still goes off if the ultrasonics are disabled, so I think it's a door switch or a fault with the alarm box itself.

Is there a diagnostic socket for the alarm? Is there a simple "flash test" option, or does it have to go to a dealer? Does anyone have an idea of how much it would cost to have a dealer/specialist interrogate the alarm?

It's in a '97 2.0 TS 16v, and it has a (later I assume) radio remote, rather than IR, so I don't have the roof-mounted switch and LED that other threads have mentioned.

Sorry for all the questions..

Thank you

Sponsored Links
Status: - Update
Posts: n/a;f=2;t=000018

Hi everyone,the alarm codes are:
Upon activating the alarm,the LED flashes to as follows:

8Hz 2.5s Door/bonnet/boot left open
On 2.5s Faulty ultrasonic sensors
16Hz 2.5s Control unit fault
Off LED fault

Upon deactivation:

1 flash RH front door
2 flashes LH front door
3 flashes RH rear door
4 flashes LH rear door
5 flashes Ultrasonic sensors
6 flashes Bonnet
7 flashes Boot
8 flashes Key operated supply cut off
9 flashes Battery supply cut off
10 flashes 3 or more simultaneous alarms

You can also do a manual diagnosis as follows:

Open the bonnet and turn the ignition key from Marcia to Stop.

Within 15 seconds press the bonnet pin switch 7 times in less than 10 seconds.

You will hear 5 beeps and after 10 seconds the indicators will flash once.

The ultrasonics are now tested, if OK the indicators will flash 3 times and you will hear 3 beeps.

Now you can trigger each sensor in turn (doors/boot/bonnet)and if Ok each trigger will give a beep and a flash.

Turn the key to Marcia and you get a brief siren and the indicators will flash for 2.5 seconds. This operation will automatically exit the test mode, but you can also exit at any point by not triggering any sensor for 30 seconds, at which point the indicators will turn on for 2.5 seconds and a beep will sound.

R Finnis
Status: - Update
Posts: n/a

I'll pop out at lunch and cause chaos in the car park!

Status: - Update
Posts: n/a
I have a similar fault with my 16V, the alarm always goes off... It flashes up code 9 on the LED which means the alarm is losing its 12V

The manual says check fuse G258 in the engine bay near the 'branch terminal board' Anybody any idea were that is ? It looks like its behind the enigine on the bulkhead according to the drawing... only Alfa could put a fuse were you carnt see it !!!

The alarm control box, looking at the drawing, seems to by under the airbox ? anybody found it ?
Status: - Update
Posts: n/a
Mike Scarf posted about replacing the battery on his alarm. Its in the wheel arch which matches up to your description of near the airbox.

R Finnis
Status: - Update
Posts: n/a
code 6 - bonnet

Alarm finally went off again! As soon as I decide to try and do something about it, the alarm behaves itself for a few days, but it went off in the car park today and flashed 6 at me.

I'll check the bonnet switch and probably just replace it. Only prob is that it's a 20 quid switch eek!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

alarm , fault

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome