A Bit Revy - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-07-03 Thread Starter
Status: PSN ID: Jack155Q4
AO Gold Member
AlfaJack's Avatar
Join Date: May 2003
Location: United Kingdom
County: Kent
Posts: 6,825
Images: 4

Member car:

1993 Alfa 155 Q4

A Bit Revy

have noticed recently that when I start the car from cold the revs will "judder" for a short while then stabilizes to normal, its like wants to stall but wont, think the RPM drops to about 6-700 for a few seconds.
Also if i am rolling along in traffic while it is cold and im only on idle revs(about 1000RPM)in 1st with the clutch out, if i press the clutch in to stop the revs climb to about 2000 without me pressing the throttle.

any ideas, im not too worried as it doesnt affect me much,

Cheers for any help guys

AlfaJack is offline  
Sponsored Links
Status: -
speed freak's Avatar
Join Date: Jan 2003
Location: A Twisted Mind..........
Posts: 4,464
That sounds like the Idle control unit sticking

Try taking it off and cleaning it and check all the breathers are clear while your on
speed freak is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

bit , revy

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome