Ventilation prob - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 16-07-03 Thread Starter
Status: -
AO Member
agha33's Avatar
Join Date: Feb 2003
Location: Germany
Posts: 106
Ventilation prob

Hi out there,

the ventilation of my car is very weak, although you can hear, that the fan is working on high speeds, there is almost no air coming out. At 34 C outside and 100 km to go for work I am almost reaching boiling point, my feet are grilled.

Is there some flap for fresh air in the vent system that is not opening? My 33 has something like that. Any way for an easy check?

Are the flaps probably working electrically?

My car is a 94 skinny 2.5 td...


agha33 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Check the external inlet vents for leaf & debris
build up,thats the usual suspect.
Or maybe you'vegot a weak/knackered fan motor.
Nick Round
Status: - Update
Posts: n/a
could try moving the air direction knob a little, I found on mine for full fresh air it should be pointed slightly to the right of the picture
Status: - Update
Posts: n/a
There is a flap underneath the wiper motor that opens when the fan is put on. Maybe it's stuck shut ????


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

prob , ventilation

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome