Blowing off! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Nick Round
Status: - Update
Posts: n/a
Blowing off!

My 2L 8valve has just blown off the grey plastic moulding (with the words twin spark written on it) that is part of the fuel system. This is the 3rd time in 7 years. Results are, it either stops the engine all together, refuses to start or like this time, starts but won't idle or rev then just dies. It didn't come completely off this time. Is this a know fault and if so is there away of attaching it more securely to the inlet manifold? Looks like its a small job that could prove beyond me as there are alot of high presure fuel pipes in the way that may need removing to get to the 4 joints.

Any advise greatly received.
Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

I`ve had a look under the bonnet on mine and can`t see the bit you are talkngn about!

Am I blind ??

Standing at the front of the car, looking at the engine - where is it ??
Chris is offline  
Nick Round
Status: - Update
Posts: n/a
Its behind the engine attached to the inlet manifold (against the bulk head). Got Roger at Peak Alfa to check it out appears the rubber mountings are on there way out and the attaching clips are the usual rubish Alfa style. Hes gonna sort it when he gets back of his Hols. So it looks like I'll have to use the 155 a bit more sparingly for 3 weeks. More classic motoring for me then
Status: - Update
Posts: n/a
I had this a couple of times with my old 8v, seemed to happen when starting the car when it was already hot. If the engine didn't quite catch it would pop back and blow off the rubbers.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome