oil temp guage - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
oil temp guage

my oil temp gauge on my 1.8 16v has not worked since 1997. I thought i might try and fix it without spending much. How can i test to see wot is broke. I guess it is probably the sender unit which is screwed into the block just next to the oil filter. Any ideas.
Sponsored Links
Status: PSN ID: Jack155Q4
AO Gold Member
AlfaJack's Avatar
Join Date: May 2003
Location: United Kingdom
County: Kent
Posts: 6,825
Images: 4

Member car:

1993 Alfa 155 Q4

Mine doesnt work either on my 2.0, i also changed the sender but made no difference! have heard since that they only show a reading if you really boot the car on a long run but i dont know if this is true or not as mine has never shown a thing,

AlfaJack is offline  
Status: - Update
Posts: n/a
They are known to give low readings on the twinny's but should show something. Try putting some power through the gauge and see what happens.

Mike Scarf
Status: - Update
Posts: n/a
Are you sure you're looking at the right sender.
Mine is at the back of the sump. The oil pressure sender is next to the filter. Thats on a 2.0 16V at least
Status: -
speed freak's Avatar
Join Date: Jan 2003
Location: A Twisted Mind..........
Posts: 4,464
Would have thought that the Oil Temperature sensor would be in the sump
speed freak is offline  
Status: - Update
Posts: n/a
My oil temp sits at about 60 normally. Giving it a real hiding I can reach 80 !!!!!
I didn't think my guage was working as it didn't move at all when I got the car. Changed the thermostat as the engine was running cold and since then it's all heated up enough to get an oil temp reading.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

guage , oil , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome