water temperature high - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
water temperature high

the water temperature of my car is high
(always over 90c, arounf 100c)
i check the coolant fan, it will run
but everytime run about 10 second, then off
what is the problem?
Sponsored Links
Status: -
AO Silver Member
Join Date: Feb 2002
Location: liverpool
Posts: 1,183

Member car:

155 Q4

could be the sensor someone should be able to give you a ohms reading to compare with if you hang around or do a search as i think its been mentioned more than once. have you checked your radiator is ok at the bottom as ive seen an 98 reg 156 with a bad rad that made it overheat all the time.
fletch is offline  
Status: - Update
Posts: n/a
The fan will cut in and out.

Check the radiator and all the pipes. Also check the coolant strength, topping mine up with some neat coolant made a lot of difference.

Status: - Update
Posts: n/a
if you wait untill its hot then feel the radiator at the top and at the bottom it should feel the same temperature..if its not then you either have a broken thermostat or the there is indeed ait in the system...also do as wrinx said,

BTW 90 deg is normal..the fan should come in at 92 deg.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

high , temperature , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome