Crazy air-conditioning - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Crazy air-conditioning


The air-conditioning of my Alfa 155 2.0 TS 16V is crazy. It works sometimes well, but only a short time.
Often, when I use any electric device (electric windows, sunroof, brake, indicators...) the ventilator starts to turn very fast during a short moment . And sometimes, the ventilator starts to turn very fast without never stopping. I have to make a random combination of air-conditioning controls [on/off; +/-;...] to stop it, it's like a game wink . The problem even occurs when the air-conditioning is off !!

Does someone know this problem ? Where could it come from ? How could I solve it ?

It's an electric problem, do you know where I can find the air-conditioning electric diagram ?

Thanks a lot !

Sponsored Links
Status: -
AO Silver Member
richward's Avatar
Join Date: Feb 2001
Location: Wombourne, UK
Posts: 1,134

Member car:

156 2.0 Veloce

Aah, the joys of italian electrics!

I'm sure if you ask nicely, Jimmybob will provide a circuit diagram for you!

Let us know how you get on...
richward is offline  
Status: - Update
Posts: n/a
i presume you have the fully electronic dash display type.......??????????????
there is very little you can do with it because all of the electronic stuff is in the front panel.
they have a self diagnosis function on them..wrinx will tell you how to get into the codes.
Status: - Update
Posts: n/a
Had the same on the climate on my V6 ....Tried to fix last year and made better for a few days now worse ...Lived with it since then ....May try to fix if someones got any good ideas ......
Status: - Update
Posts: n/a
Try this diagnostic procedure....

By Bealzbob

Status: - Update
Posts: n/a

Thank you for this link.
I have followed the diagnostic procedure step by step, but I don't know what I can do with the results.

All the displayed codes were ok excepting the following:
7 ->
The returned code is always the same as the one obtained with the previous test.

5 ->
33 instead of 32
10 ->
1- ok
2- 1З (З = reverse E ;-)) instead of 2b
3- 5b instead of 62
4- 8З instead of 94

There is no interpretation of these results on the procedure...

What can I do ?


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

airconditioning , crazy

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome