Sensors? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a

Hey does anybody know where the RPM sensor is..because this morning when I started my car the rpm on my panel wasnt moving any answers??
Sponsored Links
Status: - Update
Posts: n/a

This is from a post last June by FASUD55.

"Greetings from rainy Ireland
Like the rest of you my rev counter was very intermittent.this is how i fixed it.Undo the 2 3mm allen nuts that hold in the instrument panel.The cowling and inst panel now slide forward and out.pull it foreward and twist it gently around so that you can see the back of it .You will see a yellow coloured board with about 11 small nuts they are 5.5mm.Very very very gently turn them each a quarter turn.Only the 3 nuts behind the rev are for the rev but you may as well tighten them all.I cant emphasise enough to be carefull the board is very delicate.Be interesting to see if this cures the other cars.Best of luck.
Alan. ".

Hope it helps, haven't gotten around to trying it yet but its qiute a common problem on the 155.

John. wink
Status: - Update
Posts: n/a
thanks for the advice but it still does not seems to only move when you accelerate it to maximum rpm

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome