Problems holding revs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 18-02-03 Thread Starter
Status: -
AO Member
Bealzbob's Avatar
Join Date: Jun 2002
Location: Terenure, Dublin, Ireland
County: Dublin
Posts: 631
Images: 1

Member car:

Brera 2.2 JTS

Problems holding revs

Hi guys.
I'm just wondering what this could be.

I have recently noticed that the power in my car fluctuates slightly.

For example if I try to keep the revs at say 2,000 constantly, it will stay at 2,000 then after about 4 seconds, drift down to 1,750 then go back up to 2,000, then after another 4 seconds it'll drop down again. It will continue to do this.

It's as if it is losing power or something. Have any of you experienced this and is it a big problem or is it a new one on you (I doubt that )

Any help or suggestions would be appreciated muchly.

Alfa Romeo A labour of love or a love of labour ?
Bealzbob is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

holding , problems , revs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome