engine problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
engine problems

Hi to all great site, helpfull info…my first post.

I have 1,7 TS 8v (*95) since I bought it I have experienced engine problems; uneven runing, overfueling ( engine sounds as diesel) especially when is cold, works fine when engine gets 90 C and weather is warmer. I took car to local alfa dealer, but computer diagnostic doesnt show anything.
I have cleaned air flow sensor, checked water temp sensor with digital multimeter I gets 240 resistence when s engine hot, think thats fine.
Checked voltage on 2 lambda connectors, on one I gets 0,19V and 0,42V and on another gets 13,9V and 0V…is that fine??
I try to put cleaner for injectors in fuel, cleaned plugs and connectors…nothing changes…help please…


Sponsored Links
Status: - Update
Posts: n/a
hi cult welcome...
i must say this does sound like the water temp sensor not working when cold.
Status: - Update
Posts: n/a
'bout the same thought as above , feed back from sensor to ecu isn't correct probaly a lose contact , check the wiring
Status: - Update
Posts: n/a
thank to you people.. I will check temp sensor or replace it but still thing is srange to me cose engine is still work bad when gets 90c and weather outside is cold...
Status: -
AO Member
Jorge Delgado's Avatar
Join Date: Mar 2001
Location: Montevideo,Uruguay,South
Posts: 550

Member car:

155 TS 2.0 16 V.

Hi Zoka, no doubts it is the temperature sensor, your resistance values are not correct.
Change it, is cheap!!!

Jorge Delgado is offline  
Status: - Update
Posts: n/a
thanks to u all Im going tomorrow to buy temp sensor...

best regards to u all
Status: -
AO Silver Member
Join Date: Feb 2002
Location: liverpool
Posts: 1,183

Member car:

155 Q4

fletch is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

engine , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome