Speedmeter&wiper problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Speedmeter&wiper problems


I just brought a 155 v6 /93 2 days ago.
The problem is that the speedmeter is not working,
and the wipers only working on high speed.
Does somebody know what the problems can be?(bad contact or so in the pcb/sensor).
The problem with the wiper is also that they took out a relay (A727 509) and i dont know where to put it back in the fuse compartment.
Because i dont have a manual.
Can somebody send me a schematic diagram of the speedmeter and the wiper circuit.

Thanks from a cold holland.

Sponsored Links
Status: -
speed freak's Avatar
Join Date: Jan 2003
Location: A Twisted Mind..........
Posts: 4,464
was it the intermittant relay they took out if so goes in top left of fuse box reference speedo has cable snapped
speed freak is offline  
Status: -
Club Member
Membro Medio
ALFAPAT's Avatar
Club Member Number: 237
Join Date: Nov 2001
Location: United Kingdom
County: Moray
Posts: 1,862
Images: 6
Speedo is electronic ,probably the sensor attached to the gear box needs replaced ,can`t tell you exactly where it is but mine had gone a while ago but simple to sort,try a s/h one.cheers pat
ALFAPAT is offline  
Status: - Update
Posts: n/a
Piet have you tried the alfa romeo tuning club in Holland , i'm sure these guys can help you out...they're a bunch of 155 loons too .

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

problems , speedmeterandwiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome