Front end noises - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Front end noises

I posted this on the Alfaowners forum. It's been suggested this may be a better forum:

My 155 starts to shudder and tramp when highway driving around 110+ kph. Shuddering starts when under power going up inclines and stops when I back off the accelarator. My non-factory trained mechanic says it is the drive shaft wheel bearing housing, which he has re-welded (?). But the noise and shuddering is still there, although the severe 'donk donk donk' noise that used to appear irregularly has gone, but always has the feel that it could come back at any time. Any suggestions please? I'm not that knowledgeable about mechanics. Thanks
Sponsored Links
Status: - Update
Posts: n/a
Sorry, I shouldn't have said wheel bearing, they have been checked out and are said to be ok. I should have said 'drive shaft bearing housing' if that means anything. thanks.
Status: - Update
Posts: n/a
ive never seen a welded bearing housing before.!!!i would suggest getting a new one because it could have worn a ball flat,,also check the normal things like ball joints and bushes.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

end , front , noises

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome