Idle Speed too high - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Richard S
Status: - Update
Posts: n/a
Idle Speed too high

According to the book my 2.0L 16v should idle around 800-850. But it seems to be always at 950-1000. This is regardless of the chip fitted and all of the other buggering about I've done with the car, summer or winter motoring. Is there a way to adjust the idle speed or is it all smoke amd mirrors stuff? I cannot see anything obvious in the workshop manual. Or does everones car to that???????
Sponsored Links
Status: - Update
Posts: n/a
This has been asked recently. Do you have the last MOT emissions test slip ??? This will tell you your actual idle speed. It seems the Tacho may not be that accurate at low revs. My tacho says 950-1000rpm, but the emissions test revealed my car ticks over at 814rpm !!!

Richard S
Status: - Update
Posts: n/a
I'll have a look, i've just had the bi-annual where the f... is my paperwork session, so I know where the printouts are.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

high , idle , speed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome