service - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Nordic Blue
Status: - Update
Posts: n/a

My 155 2 litre ts Super on a '96 'P' reg came with some service history but i know i need to do the belts and what else shoud i need to do and prices what will it cost me.
Sponsored Links
Status: -
AO Member
Join Date: Jul 2001
Location: United Kingdom
County: Berkshire
Posts: 180

Member car:

Alfa 156 v6

Obviously the usual service items will need doing like the oil, oil filter and air filter but then you could do these yourself. You can check the condition of the plugs to see if they need replacing and don't buy them from an Alfa dealer if they do. Winter is upon us so check the anti freeze level and condition. The breaks are easy enough providing you don't have problems with the rear caliper hand brake assembly. This can be a pain.

The cam belt and tensioner (and balancer shaft for the 2 litre) are a piece of **** (if you have the cam locks) BUT before replacing the cam belt it would be wise for you to ensure that the cam variator is ok and doesn't need replacing. If you replace the belt and tensioner and the variator goes somewhere down the line you'll need to replace the belt and tensioner again when replacing the variator. My variator started to die at around 49,000 miles. If it's not working properly you will have what sounds like diesel knock at around 1500/2000 rpm or lower to start with especially when the engine is cold. This will gradually become worse as the variator weakens until it knocks all the time.

Good luck.
Angel is offline  
Status: - Update
Posts: n/a
The only real issue is the variator, does the engine sound a bit like a diesel?

Perhaps think about a full fluids renewal, brake and coolant. Eveything else should be covered by a standard service.

Craig T
Status: - Update
Posts: n/a
Check my post concerning Cambelts and engine "whine noise"....

If you do the belts, replace the variator anyway... it's only 65 from Alfa and is only accessible when the cambelt is off...

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome