Windscreen wiper fix - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-09-02 Thread Starter
Status: -
AO Member
Join Date: Apr 2001
Location: UK
Posts: 25
Windscreen wiper fix

I, as probably everyone has, had a problem with intermittent wiper action, sticking, juddering etc... I read the various fixes available here, from stripping down the wiper moter, replacing the system with a single sweep wiper, to changing the 155 wiper arms for a set of Alfa 146 or Volvo 440 variety.

My fix wasn't as simple as the Alfa 146 wiper arm swap, however it was straight forward and may help others.

I took off the front panel (removing wiper arms, and fixing screws), to reveal the connecting rods for the wiper drive, wiper motor and the washer tubing.

I then simply straightened up the washer tubing and in doing so stopped the connecting rods, for the wiper arms, from rubbing against the washer tubing (in my case a connecting rod had also worn through part of the tubing). The wipers have worked perfectly since.

I also found that the washer doesn't have a non-return valve fitted so to stop the tubbing from emptying the washer fluid draining back tothe reservoir, I've installed a 99p one-way washer valve ex-Halfords (UK Auot chainstore).
pilier1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

fix , windscreen , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome