V6 ticking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
V6 ticking

Iv got an early V6 which has covered just over 110000 miles.
Its developed a noisy tick at all speeds and all tempretures. Im about to flush and change the oil and filter this weekend, but I don't think this will help.
Has any body got a solution or ideas of what it could be. It is coming from the front cam cover ( I Think )

Sponsored Links
Mark T
Status: - Update
Posts: n/a
Hi Carl,
Welcome to the forum.
The V6 is a fairly "tappy" engine at tickover anyway. When I first got mine I went through similar postings before I was satisfied that it was normal for the engine to be so "ticky".
Has the noise just started, or has it been like this since you got the car??


p.s Did you get this car from a garage called the Small Car Co in Sutton Coldfield???
Status: - Update
Posts: n/a
yeh sounds like tappets...a right pain to cure.
Status: - Update
Posts: n/a
I got it too, best cure is to plant your foot on the loud pedal and keep it there


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome