Poor fuel economy and rough running. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Poor fuel economy and rough running.

Ive just read some old messages about fuel economy and how most of you are getting around 300 mile or so out of a full tank of petrol, however i am only getting around 260 or less if i give it beans. The engine seems to run ok when warm althought the power curve doesn't seem quite as smooth as it once was but the main problem is when cold it coughs at low revs (under 2K)making me look like a learner driver with no clutch control!. Apart from the Lambda sensor which i read about what in previous post what else can cause my symptons? dirty injectors? and is it something i can fix myself?.
I had thought of getting one of these Dyno Tune in a Van around to give it tune, what do people think of these?

Any help will be great.

Sponsored Links
Status: -
AO Member
Da Londo's Avatar
Join Date: May 2001
Location: Maasmechelen, Belgium
Posts: 447

Member car:

GTV 2.0

It probably is the Lambda but it could also be your air/fuel mix sensor mounted in the air intake, but it's not likely to be it, put some injector cleaning fluid in your petrol wich can help also.

BTW: I used to get 630 km out of one tank with 2x200km on a straight road going 130-140 km/h though
Da Londo is offline  
Status: - Update
Posts: n/a
Hi Slippy

Could be a number of things. When was it last serviced? Not sure but don't think these home tuners can do anything with newer cars as there are few adjustments that can be made. The oxygen sensor forms part of a "closed loop" engine management system.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

economy , fuel , poor , rough , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome