Wipers - they won't stop - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Wipers - they won't stop

I can't find this problem on previous strands. Basically the wipers on my '97 2.0 16v don't stop when the switch is in the off position. They stay on intermittent - the only way to stop them is to take the fuse out. I suspect the switch but has anyone else had the same problem?
Sponsored Links
Status: - Update
Posts: n/a
Most people can't get the damn things to work, you're lucky

I would guess the switch too but perhaps the motor is playng up???? Dunno, sorry

Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Really sounds like a dodgy column switch. Its down the scrappers for you, mush.
Chris is offline  
Status: -
AO Silver Member
richward's Avatar
Join Date: Feb 2001
Location: Wombourne, UK
Posts: 1,134

Member car:

156 2.0 Veloce

Could also be the relay...
richward is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

stop , wipers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome